If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tooltips not wrapping on 
 (Carriage Return) in title.

RESOLVED DUPLICATE of bug 67127

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 67127
14 years ago
14 years ago

People

(Reporter: Karl McMurdo, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040512 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040512 Firefox/0.8

If a links title property contains any form of linefeed or carriage return the
mozilla series of browsers insert a top left box corner or block character
rather than wrapping the the text in the tooltip.
This occurs using 
 (Carriage Return), 
 (Line Feed), or an actual LF,
CR or LF+CR, CR+LF in the html file.

Reproducible: Always
Steps to Reproduce:
1. Place the following link in a page.
2. <A HREF="/" TITLE="First Line&#13;Second Line">Link Text</A>
3. Hold the mouse pointer over the link

Actual Results:  
A tooltip pops up with "First Line?SecondLine" (The ? is a non text character)

Expected Results:  
The tool tip should be multiple line. ie:

First Line
Second Line

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.