If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nationalcity.com - Doesn't allow Mozilla

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Chris Applegate, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040308 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040308 Firefox/0.8

National City's Online Banking enrollment page (and presumably others) does some
UA detection and doesn't allow Mozilla Firefox. It recommends "upgrading" to
MSIE or NN7.

Reproducible: Always
Steps to Reproduce:
1. Go to
http://www.nationalcity.com/personal/onlineservices/onlinebanking/enroll.asp
2. Click on Enroll button.

Actual Results:  
Sent to "Alert - browser does not meet requirements" page.

Expected Results:  
Should be allowed through to enrollment form.

I sent a nicely worded email with a link to the Netscape DevEdge page on Gecko
detection to webmaster@nationalcity.com, but it bounced. Whois.internic and NC's
own contact page haven't provided me with any email addresses that look useful.
Maybe someone else can find the contact person for this site.
(Reporter)

Comment 1

14 years ago
Sent a message via web form ... it might have gone to nccgenlinfo@nationalcity.com.

Comment 2

14 years ago
Same problem in 1.7rc2 on OS/2.
Blocks: 124594
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 3

13 years ago
No change, still discriminates against Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.8a2) Gecko/20040713 Firefox/0.9.1+.

I sent a more strongly-worded message via web form and an email to the tech
contact listed in their whois entry. In included (again) the link to the DevEdge
site about UA detection, and some stuff about the recent IE vulns. If they fix
it, great, if not, I'm looking for another bank, so my evangelism efforts will
come to an end one way or another. Making a website that's Gecko-compatible but
screening out all Gecko implementations except for NN7 is just silly.

Comment 4

13 years ago
This Might be fixed, It does not give an error message about what browser to use,

Someone else Please confirm before closing this bug.

Comment 5

13 years ago
Marking fixed, since it work's for me, Re-open if it is still broken
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

13 years ago
I still get the error message. Here's a more direct link:
https://www.nationalcity.com/secure/personal/autoenroll/detect.asp?link=apply

My FF version:
Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

13 years ago
your right, I stand corrected

Comment 8

13 years ago
I sent them the following message:
---------------------------------------------
I wanted to visit your website using my linux computer and was very disappointed
with the following message:
----------------------
Your browser does not meet minimum security requirements for Online Banking. If
your browser does not support 128-bit encryption, you will not be able to enroll
in Online Banking. In addition, your browser version must be Microsoft® Internet
Explorer 5.0 or higher, or Netscape Navigator® 7.0 or higher
----------------------

I'm using Mozilla Firefox 1.0 and you should be aware that Netscape is indeed
using the Mozilla Gecko rendering engine and thus can display your site as well
as any other Mozilla browsers. After having faked my browsers identity I could
access your website without any problem.

Mozilla browsers are getting more and more market share every day (about 20% as
of october 2004) you should let these 20% potential customers access your
website as they are using 100% web standard compliant browser. (see 
http://w3schools.com/browsers/browsers_stats.asp)

In a hope that you'll remove or fix your browser detection script I'm looking
forward to hearing from you.
-- 
Jonathan Ernst

P.S. Your website's bug is discussed here in mozilla's bug tracking system:
https://bugzilla.mozilla.org/show_bug.cgi?id=244293 I'm
confident that it'll bring your company good publicity if you show that you care
about your customers.
---------------------------------------------

Comment 9

10 years ago
I can log in with their demo account in both Camino trunk and Firefox 2. FIXED.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.