Sanitizer (Simple HTML) suppresses inline images via Content-Location

NEW
Unassigned

Status

MailNews Core
MIME
14 years ago
a year ago

People

(Reporter: Mike Cowperthwaite, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Carrying this over from bug 129285.  See attachment 72795 [details] from that bug.

HTML messages can inline images that have been attached to the bug.  The <img> 
tags can refer to the attachments in one of two ways: using a cid: URI, or using 
a simple path indicator.  For the former, the attachment must have a Content-ID: 
header; for the latter, a Content-Location header.  Reference RFC 2557:
  http://www.faqs.org/rfcs/rfc2557.html

When viewing such a message as Original HTML, both techniques work fine.  When 
viewing as Simple HTML, only the cid:-specified images are shown; images using 
the relative path to Content-Location-specified images are not shown, just their 
'alt' text (if any) is rendered.

  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040510
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Updated

10 years ago
QA Contact: mime
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 2

a year ago
Confirmed when I view attachment 72795 [details] as Simple HTML, no images are shown.

Thunderbird 52.1.0 (32-bit)
Windows 7 64-bit
You need to log in before you can comment on or make changes to this bug.