Mozilla sometimes crashes when opening Acrobat files in new tab (Acrobat 5.0.8 on Linux)

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: rturnbul, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514

When opening links to .PDF files in new tabs Mozilla will sometimes crash. This
is hard to reproduce as it usually works fine....

I'm running Suse  9.0 and Acrobat 5.0.8

Mozilla 1.7RC2

Reproducible: Sometimes
Steps to Reproduce:
Open a bunch of different tabs (Html, Amazon.com) . Open
http://www.lexarmedia.com/drivers/files/JumpGear%20Windows%20Media%20plugin%20instructions.pdf

(This caused TB57755G)
Actual Results:  
Does not always crash....


Talkback IDs:

TB57755G
TB56853Q
Posted file TB57755G

Comment 2

15 years ago
dup of bug 240105 ?
Any idea if this is a recent regression, or if this has been happening with
Mozilla builds for some time now?
(Reporter)

Comment 4

15 years ago
I think this has been happening for "a while". It happens infrequently enough
that it took me a while to see the pattern.

Comment 5

15 years ago
There are a lot of related bugs that have to do with opening or closing Acrobat
Reader (PDF) files in another tab or window.  I think they are all related, it
has been a problem for a long time I find the problem now mostly when I close a
tab that is a PDF. The work around I found that works on some machines is to
click away from the Mozilla app. This clears some kind of deadlock between
Acrobat and Mozilla. It is Mozilla that is eating all the CPU as reported by
process manager anyway.

Updated

15 years ago
Keywords: crash

Comment 6

15 years ago
       Running Red Hat Workstation 3, Mozilla 1.7.2, and acroread 5.0.8-2, I see
a similar (same?) problem; all of mozilla closes when closing the window or tab
running the acroread plugin.

       I upgraded to acroread 5.0.9-1, and mozilla no longer closes on exit -
but the pdf files are never visible.  Looks like acroread starts, but dies
immediately.

thx
         anthony
Summary: Mozilla sometimes crashes when opening Acrobat files in new tab → Mozilla sometimes crashes when opening Acrobat files in new tab (Acrobat 5.0.8 on Linux)

Comment 7

13 years ago
The current version of the acrobat plugin (7.0.8) seems to work OK.  The blank window problem was a Gecko problem that has been fixed.

Is anyone still seeing this?

Comment 8

13 years ago
     Well, I don't see it in mozilla any more - but I don't use mozilla any more, so I'm not a good test case.  I do see it in Firefox 1.5.0.6 with Flash 7.0 r25 on Red Hat Workstation 4, Update 3.

    But Firefox is likely outside the scope of this bug report.

thx
    anthony
(Reporter)

Comment 9

13 years ago
I'm still seeing occasional Acrobat problems but I haven't had an actual crash due to this in SeaMonkey 1.0.4. (Acrobat will on occasion become unresponsive.)
(In reply to comment #9)
> I'm still seeing occasional Acrobat problems but I haven't had an actual crash
> due to this in SeaMonkey 1.0.4. (Acrobat will on occasion become unresponsive.)

To Robert Turnbull(bug opener):
Do you still use Acrobat 5.0.8? Or you upgraded Adobe (Acrobat) Reader?
If latter, see meta bug 336184 which is put in "blocks:" of this bug, and see dependency tree of it, and post comments to already opened & appropriate bug for problem when Adobe Reader 7.0.x.

Comment 11

13 years ago
OK, that seems good enough to say this is WFM
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Removing 336184 from blocks: because no need to track any more.
No longer blocks: 336184
(Reporter)

Comment 13

13 years ago
I'm now using Acrobat 7.0.8.
You need to log in before you can comment on or make changes to this bug.