Allow more options to recurrence of events

RESOLVED DUPLICATE of bug 259131

Status

--
enhancement
RESOLVED DUPLICATE of bug 259131
15 years ago
12 years ago

People

(Reporter: t.evans, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113

When applying a recurrence to a new event in Calendar, there is no option of
allowing the event to recure in terms of weekdays and especially business days
of a month or year or more. An example would be a credit card statement (which
in my case is due every month in terms of business days) like the 14th business
day of the month or another example would be meetings which are suppose to be on
certain business days of the month on a financial calendar. 

It would be preferable to have Calendar that upon uploading an .ics or ical file
of the holidays of a particular country to know which days are and aren't
business days for that particluar country (what are an aren't bank holidays), so
that when setting the recurrence of an event in terms of business days, a choice
of country should be given (like a drop down menu) to decide which country's
financial calendar should be used to determine what are and aren't business days
for recurrence settings of an event. Maybe even adding a default country in the
settings of Calendar to simply this might help.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Forgive me, but is your issue either that business days should be specifyable by
the user (local specific maybe) or that we need more/better options for
repitition (sp?)

Thank you

Updated

15 years ago
Summary: [RFE] Allow more options to recurrence of events → Allow more options to recurrence of events
(Reporter)

Comment 2

14 years ago
Here is how I see this function being added:

The number of business days would be defined by the user using a specific
calendar file the user would select. It might be an blank ical file except for
the weekdays that are not business days for the user's country marked as events.
It would mark weekdays that are not business days, such as a bank holidays or
New Year's Day (January 1) when it is a weekday or a national holidays (like
July 1 in Canada while July 4 in the US), as events. 

Next in the recurrance options, now using the number of business days, the user
would select how the appointments/events would repeat in terms of business days.

For example my credit card statement occurs every month on the 14th business day
of that month. Now with the weekdays that are not business days noted, the
program would go through each day of the month and know if it was a business day
or not. The program would start from the 1st of the month check if each day was
a business day or not (like a weekend or the non-business weekdays noted),
incrementing each time it is a business day until it reach the business day of
that month.

A similar method without the specific calendar for events which reoccur in terms
of only weekdays or only weekends.

Comment 3

14 years ago
I am also missing the recurrence term "last day of month" which is quite
important for monthly tasks.
(Reporter)

Comment 4

14 years ago
After trying out Sunbird (which I just discovered a few days ago) I have noticed
that the recurrance of events had the added feature of exceptions to that
recurrance. Something which is not even found in Outlook.

If something similar could be done in Calendar by expanding the list of
execptions to being given in a file, maybe in ics format, to cross off weekdays
that are not business days with the addition of counting the number of business
days in a month it might work.

I also agree with the last comment with the recurrance missing out on thing like
the last or first day/month/year as well as any multiple of the those time units
(i.e. 14th day of the month, 3rd month of the year, every 4 years, etc)

Comment 5

14 years ago
RFC2445 can store day-N-of-month, and day-N-from-month-end.
Calendar can produce day-N-of-month, but not day-N-from-month-end yet, nor
business-day-N-of-month.

To do day of month, just set the start date to the first occurrence, and in the
recurrence tab select [x] repeat every [ 1] [month]
and the options will change to include 
  (x) on the Nth of the month
where N is the day number of the start date.

day-N-from-month-end is specified in iCal by using a negative day.
RRULE:FREQ=MONTHLY;BYMONTHDAY=-3

business-day-14-of-month, where business days are Mon-Fri excluding jan1 would
be specified in iCal something like
RRULE:FREQ=MONTHLY;BYDAY=MO,TU,WE,TH,FR;BYSETPOS=14
EXRULE:FREQ=MONTHLY;INTERVAL=12;BYMONTHDAY=1
(assuming EXRULE is general, so it applies to the generated set of days before
BYSETPOS is applied.)
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> RFC2445 can store day-N-of-month, and day-N-from-month-end.
> Calendar can produce day-N-of-month, but not day-N-from-month-end yet, nor
> business-day-N-of-month.
> 
> To do day of month, just set the start date to the first occurrence, and in the
> recurrence tab select [x] repeat every [ 1] [month]
> and the options will change to include 
>   (x) on the Nth of the month
> where N is the day number of the start date.
> 
> day-N-from-month-end is specified in iCal by using a negative day.
> RRULE:FREQ=MONTHLY;BYMONTHDAY=-3
> 
> business-day-14-of-month, where business days are Mon-Fri excluding jan1 would
> be specified in iCal something like
> RRULE:FREQ=MONTHLY;BYDAY=MO,TU,WE,TH,FR;BYSETPOS=14
> EXRULE:FREQ=MONTHLY;INTERVAL=12;BYMONTHDAY=1
> (assuming EXRULE is general, so it applies to the generated set of days before
> BYSETPOS is applied.)

I would not know how the events in ical are setup specifically.

Also there are other days besides January 1 there are other events that are
exclusions. For a recent example take Labour Day, it occurs on the first Monday
of September which would not make it a business day. If you look at my first
post I stated that Calendar should have more options to its recurrance of events
that work for different situations from financial (which determining what are
business days is key) and other events such as a meeting which occurs on the
last weekday of the month, etc.

Comment 7

14 years ago
Note: bug summary seems too vague, it is not clear under what conditions this
bug could be closed.  I suggest changing summary to ask for a specific kind of
recurrence; if there are other recurrences, file other bugs later.  I suggest
change summary to:  "Allow recurrence on Nth business-day of month".

Comment 8

14 years ago
Reporter:
    I tend to agree with gekacheka's comment #7 that this is too vague of a
report.  That being said, I'll try to address a couple of the issues raised in it:

repeat every Nth business day: As said in comment #5, the standard calendar
format (RFC2445) does not define any way of calculating this/storing this
information.  If sunbird/calendar is to remain compatible with other calendar
programs (a priority for the project), then this cannot be fixed.

Holidays: Holiday files can be downloaded for a variety of countries from the
calendar website. Again, however, these can only be stored as normal events. 
There's the additional problem that some holidays are still work days (ie
Valentine's Day), and some days off aren't holidays (ie the day after
Thanksgiving).  Again, I don't think your request is plausible.

First/Last day of month (comment #4): Please see bug 259131.  This is requested
there.

I'd like to suggest that this bug be resolved, if only in favor of a few more
specific bugs that can be dealt with more easily.

Comment 9

14 years ago
See previous comment.

*** This bug has been marked as a duplicate of 259131 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.