Status

()

Core
Layout
P3
enhancement
VERIFIED DUPLICATE of bug 17309
18 years ago
18 years ago

People

(Reporter: Braden, Assigned: Pierre Saslawsky)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Style sheets are loaded asynchonously with documents. This causes the style
sheet usually to be applied after at least part of the document has already
loaded. Thus the style "pops" into effect. This is distracting.

It seems even less sensible that this behavior holds true for cached style
sheets.

See bug 6541 (which was not reopened for this since it evolved into documenting
some other problem). The current "solution" is for document authors to add a
proprietary "important" tag to the REL attribute of a LINK element referring to
an external stylesheet. This is not an adequate solution, as it requires
intervention on the part of the document author. There are millions of legacy
documents out on the Web which will not have this tag, and will consequently
cause Mozilla to inflict this popping on users.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

18 years ago
This is a dup of the now famous bug 17309 "Wait for primary style sheets before
constructing frames".


*** This bug has been marked as a duplicate of 17309 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 2

18 years ago
Marking as verified dup of 17309.
You need to log in before you can comment on or make changes to this bug.