Migrates settings into Firefox without asking

RESOLVED DUPLICATE of bug 240136

Status

()

RESOLVED DUPLICATE of bug 240136
15 years ago
14 years ago

People

(Reporter: dlessnau, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040527 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040527 Firefox/0.8.0+

Using the Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2)
Gecko/20040527 Firefox/0.8.0+ trunk build with installer on XP with clean
install (previous version uninstalled, all profiles gone, and all
mozilla/firefox directories deleted). Upon starting up for the first time,
Firefox automatically (i.e. it doesn't ask me) migrates my IE settings over to
Firefox.  This migration utility should ask before performing this migration.

Reproducible: Always
Steps to Reproduce:
1.  Uninstall any previous versions of Firefox, remove all profiles, and delete
all mozilla/firefox directories.
2.  Install new version of Firefox.
3.  Start Firefox.

Actual Results:  
The migration process automatically starts and, without asking me, imports my IE
settings into Firefox.

Expected Results:  
At the start of the migration process, it should ask me if I actually want to
import any settings, and, if so, which ones.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040527
Firefox/0.8.0+
same in branch for what it is worth.
I use 6 different browsers, not all with the same bookmark set, a choise which
one to migrate would be fine, but obviously no ?0.9 or even 1.0.
Not offering the option is not a good thing though.

Comment 2

15 years ago
I would debate a blocking 1.0?  This is a rather large intrusion to ones setup
when you migrate all the settings without an option, and giving choice here is a
pretty large polish issue. It's true that the complete newbies may always want
this to happen, no question, but a lot of us have IE around to view ONLY certain
sites which Firefox doesn't display quite right or can't be displayed at all
(mostly due to IE specific coding). In cases like this, there is no reason to
have your links, etc, migrated over from IE, since you won't be able to get to
them anyway. Mainly I just don't like the idea of zero choice in the matter though. 

Setting to 1.0? for a little discussion.
Flags: blocking1.0?

Comment 3

15 years ago
I would like to see a Yes/No prompt too. I don't want Firefox to import settings
without asking...
OS: Windows XP → All
Hardware: PC → All

Comment 4

15 years ago
I agree.. I recently downloaded a nightly and it decided that it would rather
import my NS/Mozilla profile than use my existing Firefox profile :/

Comment 5

15 years ago
This sounds like the WONTFIXed Bug 240136, dupe?

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 240136 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Flags: blocking1.0?
You need to log in before you can comment on or make changes to this bug.