Firefox returns navigator.appName as "Netscape" in JavaScript

RESOLVED DUPLICATE of bug 61071

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 61071
14 years ago
14 years ago

People

(Reporter: Philip Puryear, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040528 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040528 Firefox/0.8.0+

If you have a script in your web page that uses the 'navigator.appName'
property, Firefox will return that value as "Netscape."

Reproducible: Always
Steps to Reproduce:
1.Write a script, such as "document.write(navigator.appName);".
2.View the page in which that JavaScript is located.
3.Notice the browser's reported name.

Actual Results:  
It displays "Netscape"

Expected Results:  
It should have returned "Firefox" or "Mozilla Firefox"

Comment 1

14 years ago
This is deliberate.

*** This bug has been marked as a duplicate of 61071 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.