crashes when a java applet load is preliminary terminated [@ nsLineLayout::ReflowFrame ][@ nsObjectFrame::Reflow ]

VERIFIED DUPLICATE of bug 240105

Status

()

--
critical
VERIFIED DUPLICATE of bug 240105
15 years ago
8 years ago

People

(Reporter: Peter6, Assigned: bugzilla)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040531 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040531 Firefox/0.8.0+

as title says
java engine: Sun java 1.4.2_03

Reproducible: Always
Steps to Reproduce:
1.Open FF
2.open a page with a large applet
3.close the page before the applet is completely loaded
4.all current Firefox windows/tabs crash
Actual Results:  
crash

Expected Results:  
the Firefox window (or tab) should have closed normally

Given the large amount of crasher bugs for Java I won't dare to add a ? for any
future version.
The bug probably belongs in Browser and not in Firefox

Comment 1

15 years ago
Can you give some URL wich such large applet ?
(Reporter)

Comment 2

15 years ago
No, but any applet does.
The larger it is, the more time you have to break the process.

(Reporter)

Comment 3

15 years ago
Try http://www.ff.iij4u.or.jp/~kanada/ccm/coloring/large-applet.html
and close the window as soon as the coffeecup appears.

Comment 4

15 years ago
WFM Firefox 0.8+ 20040604/1.7 java 1.5beta2
Please try with a recent nightly and post talkback ID to this bug and give your
java version
Keywords: crash
Summary: Firefox crashes when a java applet load is preliminary terminated → crashes when a java applet load is preliminary terminated

Comment 5

15 years ago
Peter van der Woude: Are you able to reproduce crash with Firefox 0.9? Could you
provide TalkBack incident id in such case?

Comment 6

15 years ago
Does this still happen on 0.9.2?  Can this be reproduced in Mozilla Suite?
(Reporter)

Comment 7

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040728
Firefox/0.9.1+

Yes it still happens

setting -> NEW
can't speak for seamonkey, not using that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

15 years ago
where am i supposed to find the ID of the talkback
I send it a minute or so ago
(Reporter)

Comment 9

15 years ago
gottit -> TB433344Z

Comment 10

15 years ago
Is TB433344Z related to terminated java applet?

TB433344Z:
nsLineLayout::ReflowFrame 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 1187]
nsBlockFrame::ReflowInlineFrame 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3733]
nsBlockFrame::DoReflowInlineFrames 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3431]
nsBlockFrame::DoReflowInlineFramesAuto 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3332]
nsBlockFrame::ReflowInlineFrames 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3277]
nsBlockFrame::ReflowLine 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2441]
nsBlockFrame::ReflowDirtyLines 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsBlockReflowContext::ReflowBlock 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 547]
nsBlockFrame::ReflowBlockFrame 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3053]
nsBlockFrame::ReflowLine 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2316]
nsBlockFrame::ReflowDirtyLines 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsContainerFrame::ReflowChild 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
CanvasFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsHTMLFrame.cpp,
line 554]
nsBoxToBlockAdaptor::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 884]
nsBoxToBlockAdaptor::DoLayout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 626]
nsBox::Layout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1001]
nsBox::Layout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1001]
nsGfxScrollFrameInner::LayoutBox 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1256]
nsGfxScrollFrame::DoLayout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1265]
nsBox::Layout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1001]
nsGfxScrollFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 867]
nsContainerFrame::ReflowChild 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
ViewportFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsViewportFrame.cpp,
line 249]
IncrementalReflow::Dispatch 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 901]
PresShell::ProcessReflowCommands 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6336]
ReflowEvent::HandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6161]
PL_HandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpcom/threads/plevent.c,
line 674]
SETUPAPI.DLL + 0x30c24 (0x778b0c24)
Summary: crashes when a java applet load is preliminary terminated → crashes when a java applet load is preliminary terminated [@ nsLineLayout::ReflowFrame ]
(Reporter)

Comment 11

15 years ago
Yes
(Reporter)

Comment 12

15 years ago
rather, the Firefoxwindow, with page containing the applet , is closed while the
applet is being loaded.
What I see is that the whole browserwindow turns gray, all chrome (buttons etc)
are gone, only the statusbas is still normal a few secs after that the window
collapses and talkback pops up.

Comment 13

15 years ago
Reproduced with FF091+/W2K -> TB437045, TB437121:
0x0257cf17
nsObjectFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsObjectFrame.cpp,
line 1019]
nsLineLayout::ReflowFrame 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 997]
nsBlockFrame::ReflowInlineFrame 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3733]
nsBlockFrame::DoReflowInlineFrames 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3431]
nsBlockFrame::DoReflowInlineFramesAuto 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3332]
nsBlockFrame::ReflowInlineFrames 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3277]
nsBlockFrame::ReflowLine 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2441]
nsBlockFrame::ReflowDirtyLines 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsBlockReflowContext::ReflowBlock 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 547]
nsBlockFrame::ReflowBlockFrame 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3053]
nsBlockFrame::ReflowLine 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2316]
nsBlockFrame::ReflowDirtyLines 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsContainerFrame::ReflowChild 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
CanvasFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsHTMLFrame.cpp,
line 554]
nsBoxToBlockAdaptor::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 884]
nsBoxToBlockAdaptor::DoLayout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 626]
nsBox::Layout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1001]
nsBox::Layout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1001]
nsGfxScrollFrameInner::LayoutBox 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1256]
nsGfxScrollFrame::DoLayout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1265]
nsBox::Layout 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1001]
nsGfxScrollFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 867]
nsContainerFrame::ReflowChild 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
ViewportFrame::Reflow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsViewportFrame.cpp,
line 249]
IncrementalReflow::Dispatch 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 901]
PresShell::ProcessReflowCommands 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6336]
ReflowEvent::HandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6161]
PL_HandleEvent 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpcom/threads/plevent.c,
line 674]
SETUPAPI.DLL + 0x30c24 (0x778b0c24)

bug 240105 looks related, bug 136927 maybe.
Summary: crashes when a java applet load is preliminary terminated [@ nsLineLayout::ReflowFrame ] → crashes when a java applet load is preliminary terminated [@ nsLineLayout::ReflowFrame ][@ nsObjectFrame::Reflow ]
Still happens with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040731 Firefox/0.9.1+

I can't confirm this bug with Seamonkey. Anybody here who can fix it?

=> Asking for blocking Aviary1.0PR
Flags: blocking-aviary1.0PR?

Comment 15

15 years ago
jay, can you figure out where this is ranked in talkback data
Flags: blocking-aviary1.0+

Comment 16

15 years ago
This looks like a dup of 240105.   This crash has been a topcrasher for a while.
 Currently #4 on the list for Firefox 0.9.3.



*** This bug has been marked as a duplicate of 240105 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

15 years ago
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0+
Crash Signature: [@ nsLineLayout::ReflowFrame ] [@ nsObjectFrame::Reflow ]
You need to log in before you can comment on or make changes to this bug.