Javascript Date() doesnt reflect changes in local date, time and timezone without restarting.

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Zurk, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007

If i do a new Date() in javascript on a webpage in a loop and run the get local
date function (shown in a text box for example) and load the webpage in mozilla
it works fine. if i then switch to a shell and run the unix date command to
change the date and timezone, the javascript new Date() still shows the old
system date and timezone even if i change the webpage or reload it. when i shut
down mozilla and restart it the same webpage will show the new system date and
timezone correctly (which it should have done BEFORE i restarted the browser)

Reproducible: Always
Steps to Reproduce:
1. create a simple webpage with a text box which shows the current date/time
using javascript. open it in mozilla. this works ok.
2. open a xterm window and change the system date/time/timezone
3. reload the webpage in mozilla. no changes. this is the bug.
4. close mosilla and restart it with the same webpage. the new
date/time/timezone is now visible.

Actual Results:  
bug shown as noted. the new date / time /timezone is not reflected in the
webpage until mozilla is restarted. the new Date() javscript doesnt read the
correct date/time/timezone every time its called.

Expected Results:  
mozilla should be reading the system date/time/timezone everytime a new Date()
is called in javascript.

This should be fixed ASAP. For critical software such as web based time and
billing software there is a gradual drift in mozillas date/time values the
longer it stays up even though the system clock is set using NTP correctly.
date and time in javascript is extremely critical and can cause data loss.

Comment 1

13 years ago
Isn't this a dupe of bug 127246?
Depends on: 127246

Comment 2

13 years ago
WFM: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040601

WFM: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040601 Firefox/0.8.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.