Idle Flash causes Firefox to use 7-10% of CPU

RESOLVED DUPLICATE of bug 106397

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 106397
14 years ago
14 years ago

People

(Reporter: q1, Assigned: Blake Ross)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

The presence of an idle Flash movie causes Firefox to use 7-10% of the CPU
(1.33GHz G4). For an example, start Firefox clean and go to
http://us.a1.yimg.com/us.yimg.com/a/td/tdw/yho-300x250-acqinv-c126.swf, then
right click and turn "play" off. Monitor Firefox's CPU usage using top or
Activity Monitor. Since the Flash isn't playing, and Firefox isn't showing any
other pages, it should use little to no CPU.

The problem manifests whether the Flash is on a visible or invisible tab, and
whether Firefox is visible or hidden.

If you close the page containing the idle Flash, Firefox returns to using only
1-2% of the CPU (still more than it should: why doesn't it just yield?)

This is a problem for laptops, where greater CPU usage means shorter battery
lifetimes.


Reproducible: Always
Steps to Reproduce:
See "details", above.
Actual Results:  
See "details", above.

Expected Results:  
See "details", above.

Comment 1

14 years ago
q1@lastland.net, can you also reproduce this using Mozilla?
Keywords: perf
Summary: Idle Flash causes Firefox to use 7-10% of CPU → Idle Flash causes Firefox to use 7-10% of CPU
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> q1@lastland.net, can you also reproduce this using Mozilla?

I haven't tried; I have no Mozilla installation. I'll try it, but please
recommend a version to install.

Comment 3

14 years ago
Try a current nightly build for testing purposes. You should also try a current
Firefox nightly build.
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> Try a current nightly build for testing purposes. You should also try a current
> Firefox nightly build.

I've tried FireFox "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7) Gecko/20040531 Firefox/0.8.0+", and it uses between 4-5% of the CPU
under the same circumstances. I haven't tried raw Mozilla yet. BTW, this is on
OS X, for which nightly builds aren't always available.
(Reporter)

Comment 5

14 years ago
The following Flash, when idle (right click, turn off "play" and "loop"), makes
FF use 45-50% of the CPU.
http://us.a1.yimg.com/us.yimg.com/a/di/discovery_comm/yahoo_120x600_out_060204.swf
(Reporter)

Comment 6

14 years ago
OK, I've tried this with Mozilla. It (Mozilla 1.7
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040514)
works the same way.

Comment 7

14 years ago
I confirm the problem on Windows too. I found this bug, and so i won't create
another one. I got Mozilla 1.7.3 on Win2000. This happen frequently if you go on
yahoo pages. So my computer might be stucked consuming 50% of cpu i read some
news and forget to close the tags or/and the windows.

Comment 8

14 years ago

*** This bug has been marked as a duplicate of 106397 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.