about:blank is in Quirks mode, lacks Charset declaration

RESOLVED INVALID

Status

--
trivial
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: u49640, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040601 Firefox/0.8.0+ (MOOX-TK)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040601 Firefox/0.8.0+ (MOOX-TK)

ok, its a real minor "bug", but about:blank is not a Valid HTML File. it lacks
something like this
  <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
(or UTF-8)

Its nothing to be worried, but since we want people to use HTML Standards it
should be fixed

Reproducible: Always
Steps to Reproduce:

Updated

14 years ago
Assignee: firefox → general
Component: General → Browser-General
Product: Firefox → Browser
QA Contact: firefox.general → general
Version: unspecified → Trunk
Actually, putting about:blank in standards mode would break sites all over
(think places that document.write into an empty frame).

Furthermore, the <meta> tag is not at all required to be a valid HTML file.  I'm
not sure why you think it is.

Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
validator.w3.org said it lacks a charset declaration and that i sould add it somehow
That just means that your server is not sending a proper charset param in the
HTTP header.  In that case, the validator can't tell the encoding of your markup
without either you telling it explicitly or the markup having a meta tag.

Since about:blank is never sent over HTTP and hence its encoding is never in
question, this is a non-issue for about:blank.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.