Closed Bug 245302 Opened 18 years ago Closed 17 years ago

Horizontal scroll bars do not work with alps touchpad on Dell Inspiron 8600

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 202615

People

(Reporter: WATERBOYsh, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040601 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040601 Firefox/0.8.0+

The vertical scroll function is working, but the horizontal scroll function does
nothing.

Reproducible: Always
Steps to Reproduce:
1.Go to any web-site that is wider than the screen
2.Touch the touchpad in the appropiate area
3.

Actual Results:  
Nothing

Expected Results:  
The page should have scrolled right and left

I am using the June 1st nightly build with no themes, no extensions...

Win XP home with all the updates from windows update
I can confirm this bug.  I have a Fujitsu P5010D laptop as well as a Dell 600m
laptop that both have Alps touchpads.  Under the mouse settings in the Windows
Control Panel, there is a "gestures" section that allows up/down and left/right
scrolling using the edge of the touchpad.  This functionality works fine in IE
and WindowsXP.  However, only up/down works in Firefox 1.0.  Left/right does not
work.

I believe this bug is also related to bug number 266080 which deals with
back/forward gestures.  The same mouse settings allow the use of the top edge
(moving from center to left or right for page back and page forward, respective)
for gestures.  These do not work in Firefox 1.0 but do in IE and WindowsXP.

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2)
Gecko/20040601 Firefox/0.8.0+
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2)
Gecko/20040601 Firefox/0.8.0+
> 
> The vertical scroll function is working, but the horizontal scroll function does
> nothing.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.Go to any web-site that is wider than the screen
> 2.Touch the touchpad in the appropiate area
> 3.
> 
> Actual Results:  
> Nothing
> 
> Expected Results:  
> The page should have scrolled right and left
> 
> I am using the June 1st nightly build with no themes, no extensions...
> 
> Win XP home with all the updates from windows update


*** This bug has been marked as a duplicate of 202615 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.