truncatting long filename of attachment

RESOLVED FIXED

Status

MailNews Core
Attachments
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Alexander Koruno, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

Trunk
x86
Windows 2000
fixed-aviary1.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

This is a part of sample letter with attachment.
Base64-encoded filename is splitted in 2 lines.
In FileSave dialog (and not only) we see only first part of filename, which is
encoded in first line...

Content-Type: application/msword;
name==?koi8-r?B?9yDP087P18Ug1MXIzs/Mz8fJySDMxdbJ1CDIz9LP288gydrXxdPUztnKINrB?=
  =?koi8-r?B?y8/OINDP18XSyM7P09TOz8fPIM7B1NHWxc7J0SDWycTLz9PUyS5kb2M=?=
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename==?koi8-r?B?9yDP087P18Ug1MXIzs/Mz8fJySDMxdbJ1CDIz9LP288gydrXxdPUztnKINrB?=
  =?koi8-r?B?y8/OINDP18XSyM7P09TOz8fPIM7B1NHWxc7J0SDWycTLz9PUyS5kb2M=?=


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
See also bug 186974, bug 80220, and bug 112162.
Could this one be related?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> See also bug 186974, bug 80220, and bug 112162.
> Could this one be related?

May be the first bug (186974) have the same source...

Comment 3

14 years ago
Can you attach the file to this bug report ? And what is the filename ? 
(Assignee)

Comment 4

13 years ago
Created attachment 156935 [details] [diff] [review]
proposed fix

make the minimum size 15, but don't set a max - this will show large attachment
names in full, which I think is worth the potential unrulyness of the
attachment area when you have attachments with different length names.
Assignee: sspitzer → bienvenu
Status: UNCONFIRMED → ASSIGNED
(Assignee)

Updated

13 years ago
Attachment #156935 - Flags: superreview?(mscott)

Comment 5

13 years ago
actually this looks better than I thought it would for attachments with
different sizes. It looks like we end up making all of them the same width (just
the widest width of the longest attachment name).

Only problem I see so far is when your message has a horizontal scrollbar as
well, clicking on these attachments is causing the message pane area to jiggle
back and forth. I'm not sure why yet. 

Comment 6

13 years ago
actually the jiggling effect is only present when you have a horizontal
scrollbar inside the message pane box. 

vertical scrollbars do not cause any jiggling with this patch

Comment 7

13 years ago
I can now reproduce the jiggling effect even without David's patch just by
making the message pane narrower. It just happens that you'll notice it more
since we aren't constraining the width of the attachment name anymore. 

Updated

13 years ago
Attachment #156935 - Flags: superreview?(mscott) → superreview+

Comment 8

13 years ago
I checked this into the branch and the trunk for both the default theme and
pinstripe for OS X. 
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Comment 9

13 years ago
mscott, my (unfinished) patch for bug 9942 may influence or fix the jiggling,
havn't tried it.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.