The fade effect that is used on new item in download manager is extremely slow.

RESOLVED DUPLICATE of bug 227260

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 227260
14 years ago
10 years ago

People

(Reporter: Mats Åhlberg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040517 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040517 Firefox/0.8.0+

Each time i start a download it takes about 10 seconds for the item to fade in
completely while the cpu is at peak and if i remove another completed item while
it is fading the fadein is restarted and my machine bogs down for 10 more seconds.

Reproducible: Always
Steps to Reproduce:
1.Download any file.
2.Remove any previously downloaded file while the fadin is running.
3.

Actual Results:  
At first my machine goes very slowly while the fadin effect is running.
Then the fadein restarts when i remove the previous file.

Expected Results:  
The fadein should use larger steps to reduce CPU load.
The fadein should not restart when i remove another file from the list.

Comment 1

14 years ago
Try the Download Manager Performance Patch extension?
http://mozilla.org/products/firefox/releases/dlperfpatch.xpi
(Reporter)

Comment 2

14 years ago
I installed the patch mentioned in comment #1 and it got better. But the restart
of the fade when removing another item is still there but i should perhaps post
another separate bug about that.

Comment 3

14 years ago
Duplicating against bug 227260, because of the "restart of the fade when
removing another item" comment.

*** This bug has been marked as a duplicate of 227260 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.