Closed Bug 245491 Opened 16 years ago Closed 16 years ago

Unable to highlight / select text that is inserted using the :before and :after pseudo-elements

Categories

(Core :: DOM: Selection, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 12460

People

(Reporter: kevinar18, Unassigned)

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040601 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040601 Firefox/0.8.0+

When you use the :before or :after pseudo-elements in css, the text added by
these two pseudo-elements is not selectable / highlightable.
I will attach a testcase in reply to this.

---
"The :before and :after pseudo-elements"
http://www.w3.org/TR/CSS21/selector.html#before-and-after

Reproducible: Always
Steps to Reproduce:
Attached file Example of problem
Try to select the red or blue text added by the :before and :after
pseudo-elements.

Actual results:
The text is unselecteable except for what was originally in the body tag (the
black text).
Keywords: testcase
I think this is a duplicate of bug 12460.
I believe you are right.  Thank you for the information.

Marking as a duplicate....

*** This bug has been marked as a duplicate of 12460 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.