RFE: Preserve vertical scrollbar to improve performance

VERIFIED DUPLICATE of bug 72540

Status

SeaMonkey
General
--
enhancement
VERIFIED DUPLICATE of bug 72540
14 years ago
13 years ago

People

(Reporter: Jose Fandos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040531
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040531


Always show the vertical scrollbar to improve performance, as it might save an
extra layout. When there is no content to scroll the scrollbar should still be
shown, though disabled.

This is now part of Safari 1.2, IE5.x and IE6. Mozilla/Firefox preservation of
the vertical scrollbar would make browser viewport width consistent among
browsers. This would help with websites centered on the browser viewport and
that have pages short enough to fit within the browser viewport height and pages
that are taller than the viewport's height. When this occurs the pages within a
site shift right and left as you browse through pages that fit within the height
of your browser window and those that don't.

As an example to better illustrate the shifting of pages mentioned, take a look
into http://www.sonnd.com/mozilla/preserve_scrollbar.html

With IE browser share and now Safari's, there is a big chance that the creator/s
of a site won't realize that the shifting is happening, though they might have
corrected it if it would have come to their attention, since most probably the
shifting is not something they would appreciate.

There might be a legitimate reason why someone would want the current behaviour,
e.g. a popup with no chrome and limited content. For those instances in IE there
is a way to remove the scrollbar when the content doesn't extend past the height
of the browser window: <body scroll="no">. Mozilla could look to implement the
same method. It could also device another method while supporting the IE version
of it. I would be interested in knowing how Safari 1.2 deals with scroll="no".


Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 72540 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Comment 2

13 years ago
See also bug 293714, "Be smart about guessing when a vertical scrollbar is needed".
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.