Inconsistent default behavior b/w platforms (middlemouse click function)

RESOLVED DUPLICATE of bug 171132

Status

()

RESOLVED DUPLICATE of bug 171132
15 years ago
15 years ago

People

(Reporter: digitalwhoopass, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

In Windows, the default behavior when middle-clicking on a tab is to close that
tab.  In Linux, the default behavior is different; when you middle-click on a
tab, firefox will use that tab and go to whatever website is in the copy/paste
buffer.

Consistent behavior can be restored in Linux by changing the
"middlemouse.contentLoadURL" default to FALSE (accessible in about:config).

Although users have the potential ability to fix this behavior, it's relatively
buried and obscure (non-intuitive).  User experience consistency across
platforms is important; default behaviors should be shared wherever possible.

Reproducible: Always
Steps to Reproduce:
1. Open a new tab in Mozilla Firefox (any website or blank)
2. Middle-click on that new tab
3.

Actual Results:  
The tab changed locations to a relatively anonymous website.

Expected Results:  
The tab should have been closed, as it does on any Windows build by default.

Comment 1

15 years ago
Created attachment 150468 [details] [diff] [review]
patch to all.js to change unix middlemouse behaviour

The offending line is in the XP_UNIX ifdef in modules/libpref/src/init/all.js

This one line patch changes the behaviour (sets middlemouse.contentloadurl to
false on unix builds)

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 171132 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.