"Save As..., Web Page, complete" won't save any CSS "background-image:"

RESOLVED DUPLICATE of bug 115107

Status

()

Core
CSS Parsing and Computation
--
minor
RESOLVED DUPLICATE of bug 115107
14 years ago
14 years ago

People

(Reporter: tomByrer, Assigned: dbaron)

Tracking

({css1})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a2) Gecko/20040531
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a2) Gecko/20040531

When ever you try to save the full webpage, any background images declaired only
in the CSS code are not saved.

Reproducible: Always
Steps to Reproduce:
1. Go the example URL http://dromoscopio.net/
2. Menu:File/Save As.../Save As Type: Web Page, complete
3. look at saved file in a file explorer

Actual Results:  
none of the images are saved, eg
#uno div{
	background-image: url(uno.gif);
}

Expected Results:  
saved all images, even thoses declaired in CSS

default config

workaround:
1. hover mouse over desired CSS background image
2. right-mouseclick, View Background Image
3. right-mouseclick, Save Image As...

This is not not critical, but may render off-line viewing of saved webpages
impossible without editing the HTML/CSS, if the page is written with the font &
background colour the same.  (same issue when browsing some sites while the
browser is set w/images off: eg if the font color is white & the background
image is dark, but the background-color isn't set)
(Reporter)

Updated

14 years ago
Keywords: css1

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 115107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.