[standards mode]Space is inserted above headings in table cells

RESOLVED INVALID

Status

()

Core
Layout: Block and Inline
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: James Oldfield, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Opera/7.50 (Windows NT 5.1; U)  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040531

When any heading is the first line of a table cell there should be no space inserted above that heading (note: this is UNLIKE <div>s, where this is correct behaviour).  Mozilla however does insert spacing above the heading; both the headings in the example URLs show this problem.

Reproducible: Always
Steps to Reproduce:
We have no space in quirks mode, but do in standards mode.
Summary: Space is inserted above headings in table cells → [standards mode]Space is inserted above headings in table cells

Comment 2

14 years ago
I will also add that the W3C suggest that by default H1 gets a margin of .67em 0.

(In reply to comment #2)
> I will also add that the W3C suggest that by default H1 gets a margin of
> .67em 0.

...which is exactly what we do.  (It's a 'margin' shorthand property with two
values, so .67em is the top and bottom margin and 0 is the left and right margin.)

Comment 4

14 years ago
Sorry David, that was not ment for you.  Shouldn't this bug be closed?
Also, the rest of the suggested defaults are located at
http://www.w3.org/TR/CSS21/sample.html

Comment 5

14 years ago
The current layout is correct for "Standards compliance mode".

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 6

13 years ago
*** Bug 240089 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.