XUL warning in JS console when using document....focus()

VERIFIED DUPLICATE of bug 236791

Status

()

Firefox
Address Bar
VERIFIED DUPLICATE of bug 236791
14 years ago
13 years ago

People

(Reporter: Olivier Cahagne, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Build ID: trunk FF 20040602 on Win2k, have seen this consistently since at least
Mozilla 1.4 (when I  start noticing it).

Steps to reproduce:
1. Load testcase,
2. Click in input box so that caret blinks within,
3. Reload page with Ctrl-R,
4. JS console shows a warning:

Error: [Exception... "'Permission denied to get property
XULElement.selectedIndex' when calling method:
[nsIAutoCompletePopup::selectedIndex]"  nsresult: "0x8057001e
(NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame ::
file:///D:/Documents%20and%20Settings/user/Desktop/test.html :: <TOP_LEVEL> ::
line 19"  data: no]
(Reporter)

Comment 1

14 years ago
Created attachment 150337 [details]
Testcase

Comment 2

14 years ago
It occures also under linux 
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040604 Firefox/0.8.0+)

Comment 3

14 years ago
--> FireFox AutoComplete
Assignee: general → bugs
Component: Browser-General → Location Bar and Autocomplete
Product: Browser → Firefox
QA Contact: general → davidpjames
Version: Trunk → unspecified

Comment 4

14 years ago
Sounds like Bug 236791
(Reporter)

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 236791 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.