If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox Installer not capable of Silent or Auto Installs

VERIFIED DUPLICATE of bug 229706

Status

()

Firefox
Installer
VERIFIED DUPLICATE of bug 229706
14 years ago
12 years ago

People

(Reporter: Kurtis McCathern, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

When using the command line flags or the config.ini file, setting the Run Mode
to Silent or Auto, while leaving the installer functional, doesn't actually
produce an automatic or silent install.

Additionally, if one tries to edit the later parts of the config.ini to prevent
certain dialog boxes from being shown anyway, numerous problems result (in
particular, turning off most things seems to produce a successful installation,
but if the finish dialog box is turned off (to prevent the user having to click
anything) then the installer hangs.  Various combinations of on/off in that file
produce undesired behavior, but no combination produces the desired behavior (an
unattended install.)

Reproducible: Always
Steps to Reproduce:
1. Edit config.ini - change Run Mode to "Auto" or "Silent" 
2. Run setup.exe
3. Marvel at how you are being asked for path verification even though you
selected auto or silent.

Actual Results:  
Firefox prompted me for a path confirmation, even though I had asked it to do an
unattended install.

Expected Results:  
Installed the software using default values set in config.ini like Seamonkey
did/does.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 229706 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.