Web site causes instability during rendering [@ libflashplayer.so ]

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: Luke Ross, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040420 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040420 Firefox/0.8

Browsing this web site with FireFox 0.8 and Mozilla 1.6 causes both browsers to
become unstable. Typically, after a dozen pages, the browser quits unexpectedly.
I've gdb'd FireFox and it shows the problems as being a segmentation fault, but
provides no stacktrace. The steps to reproduce work for me usually on FireFox
0.8, but this is not the only way to get it to crash (in particular it is
crashable with only one tab), and may not work well under Mozilla. The point at
wich GDB suspends the process is when the flash banner has just been drawn in grey.

Reproducible: Sometimes
Steps to Reproduce:
1. Open a new blank tab
2. Navigate to URL
3. Close tab
4. Open a new blank tab
5. Navigate to URL

Actual Results:  
Browser quits unexpectedly with SEGV.

Expected Results:  
Displayed the URL

(gdb) c
Continuing.
[New Thread 71793584 (LWP 18989)]
[New Thread 93248432 (LWP 18990)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1085075328 (LWP 18982)]
0x0202d4b0 in ?? ()

Comment 1

14 years ago
can you try Firefox 0.9rc (or Mozilla 1.7rc3) and report Talkback ID if still
crashing ?
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

14 years ago
Talkback IDs TB84750Z and TB84751X (FireFox 0.9rc). Note that I cannot reproduce
the problem without the Flash plugin (my plugin identifies itself in
about:plugins as "Shockwave Flash 6.0 r69"), so this is definitely some sort of
Flash or interaction issue.

Comment 3

14 years ago
does the crash go away with Flash 7.0r25 ?
Keywords: stackwanted
Summary: Web site causes instability during rendering → Web site causes instability during rendering [@ libflashplayer.so ]
(Reporter)

Comment 4

14 years ago
Ooops, appears to be stable with 7.0r25.

Comment 5

14 years ago
Good, one more crasher fixed in v.7 !
Blocks: 211213
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Browser-General → Plug-ins
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: general → adobe-flash
Version: Trunk → unspecified
Crash Signature: [@ libflashplayer.so ]
You need to log in before you can comment on or make changes to this bug.