Remove All Sites in prefs is very inefficient

VERIFIED DUPLICATE of bug 236641

Status

()

--
minor
VERIFIED DUPLICATE of bug 236641
15 years ago
15 years ago

People

(Reporter: info, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031030
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031030

Removing all cookie sites seems to rewrite the cookie file for each site entry
removed. Seems to loop through the list, rewriting the cookie file each time.

With 100's of sites this can (and did) take several minutes at 100% CPU. Could
this be a special case in the code and just write an empty file ?


Reproducible: Always
Steps to Reproduce:
1. ensure you have some sites in the list
2. click "Remove All Sites"
3. sit and wait ...

Actual Results:  
Browser takes a significant amount of time to return, using 100% CPU.
eg with 100 sites in the list

open() prefs file
rewrite prefs files with remaining 99
close() file
open() prefs file
rewrite prefs files with remaining 98
close() file
etc ...

Expected Results:  
Just write an empty prefs file
I believe that has since been fixed...
Assignee: prefs → darin
Component: Preferences → Networking: Cookies
QA Contact: core.networking.cookies

*** This bug has been marked as a duplicate of 236641 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
V/dupe.
Please do not file bugs on anything older than 1.7b....
Status: RESOLVED → VERIFIED

Updated

15 years ago
QA Contact: core.networking.cookies → benc
You need to log in before you can comment on or make changes to this bug.