Closed Bug 24630 Opened 20 years ago Closed 20 years ago

URL bar refuses to give up focus

Categories

(Core :: XUL, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 12051

People

(Reporter: mozilla, Assigned: saari)

Details

Steps to reproduce:

1) Open Mozilla <--really! ;-)
2) Click in the URL bar to give it focus. Make sure that you have a blinking 
cursor in there indicating in is ready to accept keyboard input.
3) Open another program so that Mozilla's window falls behind and loses focus.
4) Restire Mozilla's window to the front.
5) Try to take away focus from the URL bar by clicking in the content 
area...won't happen. 
6) Try and highlight some text in the content area and press CTRL+C.
7) Go try to paste it somewhere. You can't because there is nothing there. 

What happens:
Even though Mozilla dutifully highlighted the text and looked like it would copy 
it, it did not. The cursor continues blinking in the URL bar as it if it ready 
to accept text input even though it does not accept input.

Expected:
When Mozilla lost focus, it should've also took focus away from the URL bar. 
When restored, nothing should have focus (as it is when the app first loads).

Build:
2000012008
This looks like a known bug (but a very good bug report).

Will check...
QA Contact: nobody → elig
Confirmed with 2000-01-27-08-M14 nightly binary on WinNT; the Copy item on
the Edit menu remains greyed out after a selection is made.

Workaround: click back into the URL bar (no need to type anything), click back 
in page area: copy and paste of new selection will now work properly.
Reassigning to saari, per sidr's confirmation that the bug is still present. 
(thanks!)
Assignee: nobody → saari
Component: Browser-General → XP Toolkit/Widgets
Yup, yet another dup of 12051/19973

*** This bug has been marked as a duplicate of 12051 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Ouch! That's a bug with a lot of duplicates. Thanks, Chris.
Status: RESOLVED → VERIFIED
Mass removing self from CC list.
Now I feel sumb because I have to add back. Sorry for the spam.
You need to log in before you can comment on or make changes to this bug.