If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

On first download the user should be notified of the default save folder location if then enabled

RESOLVED DUPLICATE of bug 246618

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED DUPLICATE of bug 246618
14 years ago
9 years ago

People

(Reporter: Milosz Derezynski, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

In case the default save folder option is the default from the start
(vendor-enabled), the user will never know the location unless (s)he looks it up
in the preferences, of which many users don't know, or don't want (need) to
know; additionally, it may be irritating that the browser doesn't open a file
requester to let the user choose the destination (all major browsers up to now
do that on saving links). In worst case the user won't see anything happening
when downloading, and in best case they see the download manager, which again
won't tell the location of the file either.
My suggestion would be a first time dialog at the first download that will tell
the user that all downloads are being saved automatically to the respective
folder, possibly with an option to open the download preferences, or maybe
actually making the dialog a question whether to keep that behaviour or not.

Reproducible: Always
Steps to Reproduce:
1. Install Firefox with default save folder enabled as the default option in the
profile template
2. Start Firefox for the first time (empty/no profile dir)
3. Commence a download

Actual Results:  
I downloaded a file and didn't know where it was located after the download.

Expected Results:  
At the very least telling me that downloads happen automatically to the
respective folder, and at best telling me that and offering me to set up that
behaviour.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040613
Firefox/0.8.0+
I agree

Comment 2

14 years ago
bug 246618 provides a better solution, imo.
OS: Linux → All

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 246618 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.