Closed Bug 246674 Opened 18 years ago Closed 18 years ago

Clicking links opens Internet Explorer instead of Firefox

Categories

(Firefox :: Shell Integration, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 246078

People

(Reporter: thomas, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

Clicking links opens Internet Explorer instead of Firefox. Even though Firefox
is the default browser. Start -> run -> www.someurl.com opens IE. Clicking links
in Eudora also opens IE. I have uninstalled / reinstalled Firefox but that
didn't help.

Reproducible: Always
Steps to Reproduce:
1. Start -> Run -> www.someurl.com



Actual Results:  
IE opens the URL

Expected Results:  
Firefox should have been started
I also see this problem with the final build of 0.9. I have FireFox set as the
default browser and I have tried to set IE as default and then set FireFox back
to default.

If I create a blank file called "test.htm", the icon is the icon from IE and
double-clicking on it opens the file in IE.

When I click on image links in Thunderbird 0.6, it opens the link in FireFox,
but it also opens a really annoying Open With dialog. 

Here is a thread on MozillaZine where someone reports the same problem:
http://forums.mozillazine.org/viewtopic.php?t=85155

Build Identifier:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
I think this is a dupe of 246078.

*** This bug has been marked as a duplicate of 246078 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
I also had same problem I resolved this issue myself.
I clicked on star menu-->control panel-->(in control panel I clicked on category view-->small icons)-->default program-->Firefox-->set as default browser-->yes.

This is the easiest and simplest procedure.
Regards,
Imran
You need to log in before you can comment on or make changes to this bug.