bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

keyboard focus lost when switching windows under Ion

RESOLVED DUPLICATE of bug 230097

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 230097
14 years ago
14 years ago

People

(Reporter: Joe Mason, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040602 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040602 Firefox/0.8

The Ion window manager allows multiple desktops, tiled frames on each desktop,
and multiple windows attached to each frame with tabs.  When switching tabbed
windows within a frame, Firefox often fails to regain the keyboard focus when I
return to it, leaving the window permenantly unusable for text entry.  (Note
that I'm referring to Ion tabs here - I have Firefox tabs turned off.)

Example: Open a Firefox window and go to any web page with a text entry form. 
Open some other program and attach its window to the same frame.  Tab between
these two windows.  Expected: whenever you tab back into Firefox, it will regain
keyboard focus.  Observed: eventually (generally every few minutes) it will not
stop accepting keyboard entry, though mouse entry still works.  If I open a new
window from the File menu using the mouse, the new window will get keyboard
focus just fine.

Reproducible: Sometimes
Steps to Reproduce:
1. Open a Firefox window.  Go to any web page with a text entry form.
2. Open some other window (of a different program) in another tab on the same frame.
3. Tab back and forth between the two windows.  Try to type in Firefox every
time you return to it.

Actual Results:  
Eventually, Firefox stops accepting keyboard input, although the mouse still works.

Expected Results:  
Regain keyboard focus every time you return to the firefox window.
(Reporter)

Comment 1

14 years ago
The report was incorrect: there has to be two Firefox windows open, not one
Firefox window and one misc.  When one window stops receiving keypresses, they
show up in the other.  It looks like one window keeps keyboard focus no matter
which Firefox window I tab back to.

Comment 2

14 years ago
I am seeing this same problem on RedHat WS3:

Red Hat Enterprise Linux WS release 3 (Taroon Update 1)

using Firefox:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

This is happening under GNOME 2.2 using Metacity 2.4.  I have two firefox
windows; each in their own workspace.  When going between the two, one of them
will lose all sort of keyboard input ability.  I've not been able to find a
reproducible workflow.

The only "workaround" I have found is to close the Firefox window that has
keyboard focus.  That will give the other window keyboard focus once again. 
It's quite annoying to do this because I have many tabs open and I have to close
the entire window in order to use one of the firefox windows.

Comment 3

14 years ago
If this is the same bug that I've been experiencing, a workaround is to press
Ctrl+F (find) and close the find window. The closing of the find window brings
the focus to the appropriate window. 
(Reporter)

Comment 4

14 years ago
Oh, that reminds me - turns out this was already filed.

*** This bug has been marked as a duplicate of 230097 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.