Linux installer doesn't work with warnings and errors

RESOLVED DUPLICATE of bug 246313

Status

()

Firefox
Installer
--
critical
RESOLVED DUPLICATE of bug 246313
13 years ago
11 years ago

People

(Reporter: psychictv, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.9rc/firefox-0.9rc-i686-linux-gtk2+xft-installer.tar.gz

When launching ./firefox-installer, it doesn't work and warnings and errors are
displayed in the terminal windows

Reproducible: Always
Steps to Reproduce:
1.Launching ./firefox-installer script
2.
3.

Actual Results:  
[root@localhost firefox-installer]# ./firefox-installer

** (firefox-installer-bin:3716): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (firefox-installer-bin:3716): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (firefox-installer-bin:3716): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (firefox-installer-bin:3716): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (firefox-installer-bin:3716): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (firefox-installer-bin:3716): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()
./firefox-installer: line 56:  3716 Segmentation fault      (core dumped)
./${BINNAME}-bin $@



I can provide core dump generated in the directory where I launch the script.
I'm running GNU/Linux Mandrake 10, kernel 2.6.3-4mdk, French language

Comment 1

13 years ago
My previous Mozilla browser now no longer works either!

My instance of this bug ocurred in Redhat 9.

Comment 2

13 years ago
LINUX: Debian 'sarage' Kernel 2.6.8
INSTALLING: Firefox "1.0+ 2004-16-08-trunk'
 # ./firefox-installer

** (firefox-installer-bin:4675): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (firefox-installer-bin:4675): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (firefox-installer-bin:4675): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

** (firefox-installer-bin:4675): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()
/opt/firefox-installer_1.0+_2005-01-16-07-trunk
 # Xlib: connection to ":0.0" refused by server

Xlib: XDM authorization key matches an existing client!


(firefox-bin:4694): Gtk-WARNING **: cannot open display:  

Comment 3

12 years ago
the warnings are mostly harmless and shouldn't lead to the crash.  Can you get a
stacktrace from the core?  Where were you in the installation process when it
crashed?

David: you're seeing a different bug... it looks like it can't launch firefox
after running the installer.

Comment 4

12 years ago
The Debian folk suggest my problem was caused by running an X session as 'root'.
 That evidently leads to permission problems, esp. with .xauthority

The reccommended way is logging in to a normal account then running a 'root
terminal' session for the install.  I'll try it later today with another nightly.

Comment 5

12 years ago
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050711
Firefox/1.0.5


Running FF 1.0.5 firefox_installer as root on a Fedora Core 3 box I get:

[root@localhost firefox-installer]# ./firefox-installer

** (firefox-installer-bin:3835): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

I don't have any further problems - I'm just noting this to give a bit more info
on the situation.

Updated

12 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer

Comment 6

11 years ago
see bug 246313 comment 12 for a workaround

*** This bug has been marked as a duplicate of 246313 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.