When about:blank typed and Entered, address disappears after loading blank page

VERIFIED WONTFIX

Status

()

Firefox
Address Bar
--
minor
VERIFIED WONTFIX
14 years ago
14 years ago

People

(Reporter: djc, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

If you type "about:blank" (without quotes) in the address bar and hit Enter,
Firefox loads a new blank page, but it removes the address from the address bar.

Reproducible: Always
Steps to Reproduce:
1. Open new tab or go to address bar in used tab
2. Type "about:blank" (no quotes) in the address bar and hit Enter

Actual Results:  
- Browser loads blank page.
- Address bar goes empty.

Expected Results:  
- Browser loads blank page.
- "about:blank" (no quotes) should be in address bar.
(Reporter)

Updated

14 years ago
Severity: normal → minor
This is by design, since about:blank is used as the URL for new tabs opened by
default, as well as for blank homepages.  There is no compelling reason to
preserve this value in this specific case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 2

14 years ago
But this is inconsistent with the fact, that about:cache correctly stays in the
address bar!

I also think that about:blank should be shown in the address bar, like IE does...

Where would be the problem if about:blank is also shown in new tabs and new
windows!?

Comment 3

14 years ago
I think this bug should be re-opened!
If you open a new tab, it automatically focuses the URL bar and allows you to
start typing/paste in an address, without removing a useless URL.  Forcing
people to do this on every new tab/window/blank homepage would be a usability
issue.  That function broke a while back and people were really really irritated.

about:cache is different because there is content that its good to have a point
of reference for.  A blank page is a blank page.

Comment 5

14 years ago
(In reply to comment #4)

I don't agree.

> If you open a new tab, it automatically focuses the URL bar and allows you to
> start typing/paste in an address, without removing a useless URL.  Forcing
> people to do this on every new tab/window/blank homepage would be a usability
> issue.

This problem could be solved by just having the address (the deafult:blank in
this case) selected by default. So the user could also enter directly and has
the about:blank automatically overwritten!


Further on I winf it irritating that about:blank is not shown, because
unexperienced users could think it would be possible to get an empty page by
just confirming the address bar empty!


Please consider to change this!

Comment 6

14 years ago
(In reply to comment #5)

typing error:
"winf"->"find"
I don't really believe this to be the case, at all.  Nothing you have said has
convinced me so far, and thats highly unlikely to change.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.