Overflow scrollbar shines through front elements

RESOLVED DUPLICATE of bug 191265

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 191265
14 years ago
14 years ago

People

(Reporter: Per Digre, Assigned: Brian Ryner (not reading))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608

Setting the "overflow:auto" will create a horizontal scrollbar that always goes
to the front regardless if the element has a lower z-index than any overlapping
elements. The contents of the overflow element however behaves correctly.

Reproducible: Always
Steps to Reproduce:
1. See sample, see how it behaves correctly on Windows but not on Mac.

Actual Results:  
Scrollbar is in front, shines through the menu div-tag.


Expected Results:  
Scrollbar should be behind the "menu" div-tag.
Sounds like a Mac native scrollbar problem.
Assignee: roc → bryner
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 191265 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.