Closed Bug 24713 Opened 20 years ago Closed 20 years ago

[FLOAT] Floating images inside table problematic

Categories

(Core :: Layout: Tables, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: run2000, Assigned: buster)

References

()

Details

Overview Description:
The bottom two floating images within the main article text have problems.

The left aligned floating image is rendered lower and off to the side of where the
text wraps around wherer it should be.

The right aligned floating image has the text on top of the image, and no text wrap
is apparent.

Steps to Reproduce:
1) Open Mozilla
2) Go to the URL above

Actual Results:
The two floating images near the bottom of the article are not floating correctly
within the text of the article.

Expected Results:
All floating images in the article should have the text wrapped around them.

Build Date & Platform Bug Found:
Mozilla build 2000012108, on Windows NT 4 Workstation, Service Pack 5

Additional Builds and Platforms:
- Doesn't occur on:
     Opera 3.61, Windows NT 4.0
     Internet Explorer 5.01, Windows NT 4.0

Additional Information:
Looking at the HTML source, the floating attribute of the images is not being
"cleared" in subsequent paragraphs, ie. there is no <p clear="all"> or 
<br clear="all"> until the very bottom of the article.
May be reflow related, since I can't reproduce this bug when I copy the HTML code
to my local machine. Reloading the original site over a 56k modem line
consistantly reproduces the problem, however.
shooting for M15.  Note that the submitter says this happens over a slow line, 
but not on a local copy of the file.  Maybe an image incremental reflow issue?
Target Milestone: M15
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
This bug looks to have fixed itself recently. Marking fixed.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Verified fixed.
You need to log in before you can comment on or make changes to this bug.