Closed Bug 247162 Opened 17 years ago Closed 17 years ago

"open link in new tab" makes top tab lose focus and breaks wheel scrolling

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: caucci80, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

I am viewing a webpage.  I see a link that I also want to open in another tab in
the background.  So I hold down the Ctrl button as a click the link, and, as
expected, the webpage opens in a new tab in the background, while my original
page remains in the foreground.  BUT, my foreground window has lost its focus! 
For example, if I begin to then use my mouse scroller to scroll down the page,
nothing happens.  I must regain focus of my foreground tab by clicking in some
random place on the webpage.  The program should, needless to say, do that for
me, so I can avoid the extra click, and also the search for a good place to click.

Thanks!


Reproducible: Always
Steps to Reproduce:
1. go to any webpage that you know will be long enough that you can scroll on it
2. on that webpage, open any link you want in a new tab in the background
3. then try to scroll down the foreground tab USING THE SCROLLER ON YOUR MOUSE
(NOT THE PAGE UP PAGE DOWN BUTTONS) 

Actual Results:  
was not able to until I clicked somewhere in the webpage to regain focus of the
page.

Expected Results:  
Regain focus of the page automatically so that when I scrolled with my mouse,
the page scrolled down, rather than me having to perform a click in the webpage
in a random spot.
are you sure that "select new tabs opened from links" is disabled in
Tools->Options->Advanced ?
Dimitrios: you're misreading the bug.  The reporter said that the new tab is
correctly opened in the background, but something happens (possibly involving
focus) that makes mousewheel scrolling stop working in the foreground tab.

That said, I can't reproduce the bug with Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.8a2) Gecko/20040601 Firefox/0.8.0+.
Summary: "open link in new tab" makes top tab lose it's focus → "open link in new tab" makes top tab lose focus and breaks wheel scrolling

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.