Closed Bug 247355 Opened 18 years ago Closed 18 years ago

Windows XP error when opening URL shortcuts

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 246078

People

(Reporter: bugs, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

After installing of Friefox 0.9, Windows XP gives an error dialog box when I
open a shortrcut (.URL file): "Windows cannot find '[url]'. Make sure you typed
the name correctly, and then try again. To search for a file, click the Satrt
button, and then click Search."

1) I didn't type the name, I was opening an "InternetShortcut" file.
2) the page *does* open a new Firefox window

Firefox is my default browser, chosen both by the MS-supplied method (in the
Add/Remove Programs capplet) and from within Firefox ("Firefox doesn't appear to
be your default browser...").

Also related, every time makes a new window appear. In Firefox 0.8, the shortcut
opened in the current window (and, of course, there was no error dialog).

This makes me wonder: is there a problem with DDE? Normally, I'd expect it to
communicate with the current process instead of starting a new one (this also
goes for links clicked within Outlook Express). Is this the same problem as the
process communication under Linux?

Reproducible: Always
Steps to Reproduce:
1. create a shortcut to a page (e.g. drag item from address bar to desktop)
2. double-click shortcut
3. profit!

Actual Results:  
Error dialog appears, page opens in new window.

Expected Results:  
Page should open in existing window, there should be no error dialog.

*** This bug has been marked as a duplicate of 246078 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Duplicate of this bug: 407070
You need to log in before you can comment on or make changes to this bug.