Custom install over previous installation should respect previous selection of components

VERIFIED DUPLICATE of bug 168239

Status

SeaMonkey
Installer
--
minor
VERIFIED DUPLICATE of bug 168239
14 years ago
13 years ago

People

(Reporter: Hans Schleichert, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.8a2) Gecko/20040615
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.8a2) Gecko/20040615

Whenever I install a new nightly build using the Custom install type, the
installer selects ALL components in the first place. I'd rather it deselected
components that aren't currently installed. On the other hand, the installer
should install a recent version of additional components, like the mozilla
calendar, when it finds such a component is currently installed.

Reproducible: Always
Steps to Reproduce:
1. Download nightly mozilla
2. Install over current installation
3. Select custom installation


Actual Results:  
All components are selected

Expected Results:  
Select only those components which are currently installed

Comment 1

14 years ago
In general it is not recomended to install over a previous version. A better
solution would an update feature. See bug 214360 for this.
So in my opinion this should be WONTFIX.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 168239 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.