Windows error message occurs when loading .url shortcut files

VERIFIED DUPLICATE of bug 246078

Status

()

--
minor
VERIFIED DUPLICATE of bug 246078
15 years ago
15 years ago

People

(Reporter: draimus, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Switched from Mozilla 1.6 to Firefox 0.9.  Mozilla 1.6 was uninstalled after
settings had been imported to Firefox 0.9.  Firefox was set as the default
browser when asked.  

Later attempts to use existing IE internet shortcut files (.url) causes an error
that says: 
"Windows cannot find "<URL>".  Make sure you typed the name correctly, and then
try again.  To search for the file, click the Start button, and click Search."
In spite of the error, Firefox starts (or opens a new window) and loads the URL
with no problems.  Same results occur when typing in a URL in the Start->Run
windows dialog or clicking on a news link in Yahoo IM.

Using Windows' “Set Program Access and Defaults” utility to switch the default
browser to IE and back to Firefox does not solve the problem (though the url
files work for IE).  Letting Firefox set itself to be the default browser does
not solve the problem.

Reinstalling Mozilla 1.6 (browser only) allows the url files to work with BOTH
Mozilla and Firefox, depending on which one is the default browser. 
Uninstalling Mozilla 1.6 causes the problem to reoccur again.  Reinstalling
Firefox (without Mozilla present) does not correct the problem.

Checking the file associations for html and url types (when both Mozilla and
Firefox were set as default browser) did not expose any obvious problems.

Reproducible: Always
Steps to Reproduce:
1. Install Firefox .9 while Mozilla 1.6 is present.
2. Set Firefox to be the default browser.
3. Uninstall Mozilla 1.6.
4. Double click a .url shortcut. 

Actual Results:  
Windows will pop up an error window that reads "Windows cannot find "<URL>". 
Make sure you typed the name correctly, and then try again.  To search for the
file, click the Start button, and click Search.".  Firefox will load the page
specified in the .url shortcut normally.

Expected Results:  
Firefox loads the page specified in the .url file with no errors from windows.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 246078 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.