Expand/collapse widget still present for bookmark folders even if there's no subfolders in Firefox's 2-pane Bookmark Manager

RESOLVED DUPLICATE of bug 76525

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 76525
14 years ago
12 years ago

People

(Reporter: shadytrees, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040619 Firefox/0.9.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040619 Firefox/0.9.0+

In the Bookmark Manager's folder pane in the new Firefox branch nightlies that
have the 2-pane Bookmark Manager, it displays all the folders in tree hierarchy
form. However, when a folder has no subfolders, the collapse/expand widget still
exists (and still functions, albeit without displaying the non-existent
subfolderes). (I think) The standard behavior for a folder with no subfolder is
to not display a collapse/expand widget at all, like in Windows Explorer.

In the attachment, the folders "SubBlogs" and "SuperBlogs" have no subfolders,
even though the collapse/expand widget still exists. However, the "Blogs" folder
does have subfolders, so the collapse/expand widget should exist.

The "Shortcuts" folder also has no subfolders.

This poses confusion to the user since the user no longer knows which folders
have subfolders and which don't unless the user manually clicks on the widget
(which still switches between expand and collapse states).

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 151229 [details]
A screenshot of the folder pane in Firefox's new 2-pane Bookmark Manager

Comment 2

14 years ago
Confirming.

Steps to reproduce:
1) create new folder
2) add bookmark to newly created folder
3) delete newly added bookmark

Actual Results:
expand/collapse widget is still present

Expected Results:
no expand/collapse widget
(Reporter)

Comment 3

14 years ago
Er, I think you're referencing to the old 1-pane Bookmarks Manager since
bookmarks don't appear in the folder tree in the two-pane Bookmark Manager.
(Reporter)

Comment 4

14 years ago
This also applies for the extended Add Bookmark dialog, but that's another bug
for another day.

Comment 5

14 years ago
Left panel opens with a Minus widget at Bookmarks level, when a Plus widget
should be displayed. Clicking on the widget brings up a Plus widget which, when
clicked, expands the tree. However, both panes are not coordinated, when you
click on a folder on the left pane the right pane does not diplay the contents
of that folder.

Comment 6

14 years ago
confirming with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040620 Firefox/0.9.0+ branch build, after following steps in comment #2.
Restarting Firefox doesn't affect. However, the widget disappears when reverting
to the official 0.9 milestone release.
Raanan: what you report are two different bugs, of which none is related to this
one. Please open new bugs if it has not already been filed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

14 years ago
(In reply to comment #6)
> Restarting Firefox doesn't affect. However, the widget disappears when reverting
> to the official 0.9 milestone release.

Scratch that. The redundant widget disappears after shutting down and restarting FF.

Comment 8

14 years ago

*** This bug has been marked as a duplicate of 76525 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.