Sunbird build is broke (2004-06-19) due to semi-singe-profile

RESOLVED INVALID

Status

Calendar
General
--
critical
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Justin, Assigned: Benjamin Smedberg)

Tracking

Details

Attachments

(1 attachment)

59.81 KB, application/x-gzip
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040619 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040619 Firefox/0.9

Pulled mozilla trunk and tried to build sunbird. Build failed with following error:

../../../dist/lib/libxulapp_s.a(nsNativeAppSupportBase.o)(.text+0x42d): In
function `nsNativeAppSupportBase::CreateSplashScreen(nsISplashScreen**)':
/prj/mozilla/sun/trunk/mozilla/sun-dbg/toolkit/xre/nsNativeAppSupportBase.cpp:148:
undefined reference to `NS_CreateSplashScreen(nsISplashScreen**)'
collect2: ld returned 1 exit status
gmake[4]: *** [MozillaSunbird-bin] Error 1


Reproducible: Always
Steps to Reproduce:




My .mozconfig is as follows:

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/sun-dbg
mk_add_options MOZ_MAKE_FLAGS=-j2
ac_add_options --enable-calendar
ac_add_options --enable-crypto
ac_add_options --enable-extensions=cookie,pref
ac_add_options --disable-optimize
ac_add_options --enable-plaintext-editor-only
ac_add_options --enable-static
ac_add_options --disable-accessibility
ac_add_options --disable-activex
ac_add_options --disable-activex-scripting
ac_add_options --disable-composer
ac_add_options --enable-debug
ac_add_options --disable-installer
ac_add_options --disable-jsd
ac_add_options --disable-ldap
ac_add_options --disable-logging
ac_add_options --disable-mailnews
ac_add_options --disable-mathml
ac_add_options --disable-necko-disk-cache
ac_add_options --disable-oji
ac_add_options --disable-profilesharing
ac_add_options --disable-view-source
ac_add_options --disable-shared
ac_add_options --disable-tests
  
export MOZ_SUNBIRD=1
mk_add_options MOZ_SUNBIRD=1
(Reporter)

Comment 1

14 years ago
Created attachment 151236 [details]
output of gmake

This is the output of the gmake when I attempt to build sunbird
this very much looks like a result of the semi-single-profile landing.
bsmedberg, any change on fixing this? this totally blocks sunbird work.
Assignee: mostafah → bsmedberg
Severity: normal → critical
Summary: Sunbird build is broke (2004-06-19) → Sunbird build is broke (2004-06-19) due to semi-singe-profile
(Assignee)

Comment 3

14 years ago
Actually, this is the result of a not-quite-clean build. Make sure you don't
have any CVS "<foo> is in the way." messages, and remove all of
<objdir>/toolkit/xre. What happens is there is an "old" version of
nsNativeAppSupportBase.cpp which was nsinstalled from xpfe/bootstrap. This is no
longer the case, and the old file can cause the build error you're describing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

14 years ago
Yep.... a normal clobber won't do it. You have to actually rm -fr objdir

After doing that, it compiled fine
Could you warn about that somewhere, in the newsgroups or so? I guess the same
will be ture for firefox and thunderbird.
It builds now, but it doesn't start. It is in a restart-loop.
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.