double-click selects punctuation along with word

VERIFIED DUPLICATE of bug 16352

Status

()

Core
Selection
P3
normal
VERIFIED DUPLICATE of bug 16352
18 years ago
18 years ago

People

(Reporter: Neil Cronin, Assigned: mjudge)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Steps to Reproduce:
1) double click any of the below lines of html

Actual Results: punctuation gets selected along with word

Expected Results: only word gets selected (as with other browsers, word-proc's,
everything-except-MS-notepad, etc)

Build Date & Platform Bug Found: 2000012116

Additional Builds and Platforms Tested On:  none

Additional Information: It seems like there should be an array of cases where
the selection stops.  it seems like that case is now only the space character.

test,	<br>

test.	<br>

test/	<br>

/test	<br>

test?	<br>

test'	<br>

test"	<br>

test;	<br>

test:	<br>

:test	<br>

(test	<br>

test)	<br>

`test	<br>

=test	<br>

test=	<br>

Comment 1

18 years ago
Created attachment 4468 [details]
Included testcase as attachment for testing

Comment 2

18 years ago
Confirmed on NT.

Actually, double-clicking inside the word is including the space after the
word too. That is bug 11544, "double-click selection includes extra space",
ASSIGNED, M15. In these cases, the punctuation must be being considered part
of the word.

Tested with: 2000-01-20-08-M13 nightly binary on Windows NT 4.0sp3.

Comment 3

18 years ago
This is a duplicate of 16352.

Neil, I can attach the test case from that bug report to the bug if you'd like to 
personally double-check (and/or identify omissions in the test case.)

Thanks!


*** This bug has been marked as a duplicate of 16352 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verifying as duplicate. Left note in 16352 to check your excellent examples in 
this bug report upon verifying that bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.