If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incorrect status for cookie exceptions entered by clicking "Allow for Session" button in dialog

RESOLVED DUPLICATE of bug 230525

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 230525
13 years ago
11 years ago

People

(Reporter: Jonathan Goforth, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

When the "Use my choice.." check mark is selected and "Allow for session" button
is pressed in Allow/ Deny Dialog Box, the site is added to Exceptions List. The
status for the site in Mozilla 1.7 is "allowed for session" in Firefox the
status is "Blocked". It may not be desirable to add a third status option but if
that is the case, "Allowed" should be used, since cookies for that site are in
fact allowed. It should be notes that the actual operation of allowing cookies
and getting rid of them after a session is correct, it just isn't labeled correctly.

Reproducible: Always
Steps to Reproduce:
1. Set browser to ask for all cookies
2. Go to any web site that will request a cookie that is not already on your
exception list.
3. Select "Use my choice for all cookies on this site."
4. Click on the "Allow for session" button
5. Navigate to the Exceptions list and look at the status

Actual Results:  
Status for added site is "Blocked"

Expected Results:  
Status should be either "Allowed for session" or "Allowed"

*** This bug has been marked as a duplicate of 230525 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.