Closed Bug 24809 Opened 20 years ago Closed 20 years ago

[choose folder] cannot displayed Japanese folder name.

Categories

(Core :: Internationalization, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 23705

People

(Reporter: m_kato, Assigned: bugs)

References

Details

Attachments

(1 file)

- Step
1. select [Edit] - [Preferences...]
2. select [Advanced] - [Cache] item.
3. click [Choose Folder...] buttom.
4. select Japanese folder name (i.e. C;\¥Æ¥¹¥È)
5. click [OK]

- Result
[Disk cache folder item] is "C;\eXg", not "C;\¥Æ¥¹¥È".
I believe this problem is caused by the nsFileSpec which do not use PRUnichar* 
or nsString in the interface but using char*. Assign to trudelle and CC erik and 
don. Please define your interface using PRUnichar* and nsString instead of 
char*. Otherwise, we have no way to have a good i18n story. Thanks.

Assignee: ftang → trudelle
reassigning to dougt, who (I think) owns these APIs.
Assignee: trudelle → dougt
Need to convert to nsIFile.  It returns UTF8 strings.  
Target Milestone: M15
Changed Platform and OS due to repro on MacOS 8.6
thanks, ayatsuki san.
OS: Windows NT → All
Hardware: PC → All
This component should be using nsIFile as it return UTF8 strings.  
On BUG 23384, nsFileWidget was fixed.
So, you should fix nsFileSpec and nsSimpleCharString.
In BUG 22863, I added nsFileSpec::GetNativePathString method.
Probebly, using this method, this bug will be able to fix.
assigning to ben.
Assignee: dougt → ben
require nsIFilePicker, as there is no UI presently for nsIFile. 

pushing out. 
Status: NEW → ASSIGNED
Target Milestone: M15 → M20
Attached patch fix codeSplinter Review
add CCing ftang, and depends of 28424

This problem is bad cast in nsFilePath::nsFilePath(const nsString& inString, 
PRBool inCreateDirs).  (not nsIFilePicker)

please review and check-in.
Blocks: 28424
Keywords: nsbeta2

*** This bug has been marked as a duplicate of 23705 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.