multiple downloads of files with different versions eg firefox-0.9

RESOLVED DUPLICATE of bug 231048

Status

()

Toolkit
Downloads API
--
trivial
RESOLVED DUPLICATE of bug 231048
14 years ago
10 years ago

People

(Reporter: Andrzej Borsuk, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7) Gecko/20040615 Firefox/0.9

Download manager renames files when they are downloaded twice (by mistake)
using scheme filename-version.
Its makes BIG problem when downloading different versions of files creating
nonexistent versions eg firefox-1.9.


Reproducible: Always
Steps to Reproduce:
1. download http://somwhere.net/file-1.0.tar.gz
2. download http://somwhere.net/file-1.0.tar.gz (you get file-2.0.tar.gz on your
local drive)
3. download http://somwhere.net/file-2.0.tar.gz (now you get file-3.0.tar.gz)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.