Status

()

RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: jan.ruzicka, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040608

(As there is no Networking category for Firefox, this bug has to be filed here
in General.)
The gopher browsing in Firefox is weak.

It is actually a behavoir carried over from 1.7 (bug 194220).

One of the problems is missing information tag. 
Can the fix from bug 118438 be incorporated into firefox?

(Can this bug be one for general linking of gopher bugs in FF?)

Reproducible: Always
Steps to Reproduce:
(Reporter)

Updated

14 years ago
Blocks: 194220

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

14 years ago
HMM. Jan, is this bug aiming at applying the patch for bug 118438 onto the
aviary branch for Firefox 1.0 (since the bug landed already on the shared
mozilla/firefox trunk).

I think, that this is a good idea since Firefox 1.0 would become a recommended
browser for the (small but still existing) gopher community. I think that Ben
Goodger has to decide, which fixes are moved to the aviary branch, therefore I
added Ben to the CC list (sorry Ben if this isn't ok).

Looking at bug 118438 makes me feel that the patch wasn't checked in on the
stable 1.7 branch because the 1.7 release was too close and it wasn't considered
to be checked in on the Fx aviary branch because Darin Fischer didn't know how
to do so.

Comment 2

14 years ago
requesting blocking-aviary1.0 to get attention of firefox project management. 
it does no good to cc ben goodger directly.  i don't think he reads bugmail.
Flags: blocking-aviary1.0?

Comment 3

14 years ago
Why is this blocking 1.0?
Flags: blocking-aviary1.0RC1-
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0-

Comment 4

14 years ago
Setting this flag wasn't aiming at blocking a firefox release, but getting the
attention of the firefox release managment instead (for the reasons listed above). 

Since all releases after firefox 1.0 will be based on mozilla 1.8 or later (thus
including the bugfix), this bug only makes sense for firefox 1.0. So it should
be marked either blocking 1.0 or wontfix. Other choices do not make sense IMHO.

Comment 5

14 years ago
Well, since setting the blocking flag to ? didn't obviously work, I cc'ed dwitte
since he synced some network related stuff between the trunk and the branch
lately . Maybe he reads bugmail and can help to check the fix for bug 118438
into the branch.

Darin Fisher told that it isn't a risky patch, but doesn't know, how to land it
on the branch. The goal is to make Firefox a recommended browser for the
gopherspace, and therefore gaining support from the gopher community.

If nobody wants to land the bug 118438 fix on the branch, please mark this bug
as wontfix. If someone lands this fix, please mark it fixed and add the
information to the status whiteboard of bug 118438.

Comment 6

14 years ago
@Jan: 

Since Firefox 1.0 is out and this bug doesn't serve any purpose any longer, can
you mark this as WONTFIX or INVALID?

Comment 7

14 years ago
(In reply to comment #6)

NAK. The bug is still valid. That Firefox has reached 1.0 doesn't mean the bug
ceases to exist.
(Reporter)

Comment 8

14 years ago
This bug is for getting the gopher support to Firefox in general.
It does not aim at any particular version.
(Version 1.0 was just the closest upcoming release.) 
since firefox does not limit the protocol handlers it contains, all releases of
firefox already contain gopher support.

Comment 10

14 years ago
NAK. Last I checked Gopher support was still limited.
Without the information tags gopher support is meaningless.

The point of this bug is not getting any level of support but actually get a
*decent* level of support. The bug regarding info tags for example was resolved
as fixed although the problem still exists in Firefox (20041001).
> Without the information tags gopher support is meaningless.

possibly so, but all firefox versions after 1.0 will get that support
automatically, since it's fixed on trunk, and 1.0 was on a branch.
Assignee: firefox → nobody
Why is this bug still open? Bug 118438 was fixed a long time ago, it will be in Firefox 1.5 which will be released shortly. Generally, gopher bugs are core networking bugs, not specific to Firefox, so having an open bug with a summary of "gopher for Firefox" isn't very useful.

Comment 13

13 years ago
The bug tried to push the important i-itemtype patch in onto the branch in time for the Firefox 1.0 release. Without success as we know now (and probably not in a valid way known for bugzilla bugs).

Now that we know that this is now fixed (with more than 12 months of delay) you are free to mark this bug as fixed or invalid ;)
INVALID per comment 13.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.