pref "javascript.allow.mailnews" is obsolete and should be removed

RESOLVED FIXED in Thunderbird 3.0b4

Status

MailNews Core
Backend
RESOLVED FIXED
14 years ago
8 years ago

People

(Reporter: Henrik Gemal, Assigned: Magnus Melin)

Tracking

({fixed-seamonkey2.0})

Trunk
Thunderbird 3.0b4
fixed-seamonkey2.0

Firefox Tracking Flags

(status1.9.2 beta5-fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
currently it's in:
http://lxr.mozilla.org/mozilla/source/modules/libpref/src/init/all.js#422
it should be moved to a mailnews specific .js file
Product: Browser → Seamonkey

Updated

9 years ago
Assignee: general → nobody
Component: General → Backend
Product: SeaMonkey → MailNews Core
QA Contact: general → backend
(Assignee)

Comment 1

9 years ago
The pref is now obsolete, and should be removed - see bug 504965 comment 8.
Hardware: x86 → All
Summary: pref "javascript.allow.mailnews" should be move to mailnews specific pref → pref "javascript.allow.mailnews" is obsolete and should be removed
Target Milestone: --- → Thunderbird 3.0b4
(Assignee)

Comment 2

9 years ago
Created attachment 396140 [details] [diff] [review]
comm-central proposed fix

Removing the dead ui from seamonkey. You may want to figure out how much sense it makes to have the single [ ] Browser section there and such, but let's leave that to another bug.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #396140 - Flags: superreview?(neil)
Attachment #396140 - Flags: review?(mnyromyr)
(Assignee)

Comment 3

9 years ago
Created attachment 396141 [details] [diff] [review]
mozilla-central proposed fix

dmose, want to review the m-c patch? dunno who would be a good reviewer for something like this, but as you're the one who implemented the removal of the pref...
Attachment #396141 - Flags: review?(dmose)

Updated

9 years ago
Attachment #396141 - Flags: review?(dmose) → review+
Comment on attachment 396141 [details] [diff] [review]
mozilla-central proposed fix

r=dmose; thanks for the patch!

Updated

9 years ago
Attachment #396140 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 5

9 years ago
mozilla-central part checked in
changeset:   31791:8e21c74914f7
http://hg.mozilla.org/mozilla-central/rev/8e21c74914f7

Comment 6

9 years ago
Comment on attachment 396140 [details] [diff] [review]
comm-central proposed fix

Thanks for caring!
Attachment #396140 - Flags: review?(mnyromyr) → review+
(Assignee)

Updated

9 years ago
Duplicate of this bug: 458881
(Assignee)

Updated

9 years ago
Attachment #396140 - Flags: approval-seamonkey2.0?

Updated

9 years ago
Attachment #396140 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
(Assignee)

Comment 8

9 years ago
changeset:   3545:6169983ce2ac
http://hg.mozilla.org/comm-central/rev/6169983ce2ac

->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Blocks: 514969

Comment 9

9 years ago
Adding fixed-seamonkey2.0 keyword so the queries for approved but not fixed bugs don't catch that bug.
Keywords: fixed-seamonkey2.0

Comment 10

8 years ago
(In reply to comment #3)
> Created an attachment (id=396141) [details]
> mozilla-central proposed fix

Should this be landed on 1.9.1/.2 as well? If so, I guess you should request approval. I saw that some users are confused by finding the pref in about:config in SeaMonkey 2.0, thinking it would be any good to set it to true.
Not confused, hoping against all hope it was hidden switch to turn it on. I've have had JavaScript on since netscape Navigator 3.0.1.a days and have never had any problems with it.
(Assignee)

Comment 12

8 years ago
Comment on attachment 396141 [details] [diff] [review]
mozilla-central proposed fix

Dead pref removal to avoid confusion.
Attachment #396141 - Flags: approval1.9.2?
These bugs landed after b4 was cut. Moving flag out.
status1.9.2: --- → final-fixed
Comment on attachment 396141 [details] [diff] [review]
mozilla-central proposed fix

approval1.9.2 requests aren't currently being monitored, since we're nearing RC freeze and there are too many outstanding requests, so I'm clearing this request. Feel free to re-request approval if you are confident that it's worth drivers' time to consider whether this non-blocker needs to land for 1.9.2 at this stage.
Attachment #396141 - Flags: approval1.9.2?
You need to log in before you can comment on or make changes to this bug.