Closed Bug 24829 Opened 23 years ago Closed 10 years ago

RFE: Store bookmarks as images, too...

Categories

(SeaMonkey :: Bookmarks & History, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: roland.mainz, Unassigned)

References

Details

(Keywords: helpwanted, Whiteboard: [2012 Fall Equinox])

Most people including me store most information as visual information (I won't
explain this in details, AFAIK this would overflow the underlying mySQL database
=:-).
What about the idea of making the currently "bookmarked" page to an icon which
gets stored with the bookmarks, too (see IMPLEMENTATION in my next add-on of
this RFE).
Moving througth the bookmarks and stopping more than two second will load and
display the icon in the menu bar - giving the users an additional hint for
finding the matching record in memory... :-)
This bug heavily depends on bug 16959 (RFE: For a bookmark provider
architecture).
Depends on: 16959
Implementation:
The implemenation is (AFAIK) simple: Grab the current page's view and save it as
a scaled-down PNG or JPG image (what about TIFF ?). The bookmark.html only
contains a reference to this image.

Best would be to get this implemented with the "bookmark provider" architecture
- the provider itself manages the storing/loading of the image and playing
around with the references.

Any comments ?
Severity: normal → enhancement
m18
Target Milestone: M18
Wouldn't this make handling bookmarks unbearably slow, and bookmarks storage 
(especially for someone with a couple of hundred bookmarks) unbearably bloated?
Performance depends on how the "bookmark provider" implements this (bug 16959).
I don't think it is a big problem to handle this; a possible implementation may
still use the current bookmark format and store the images elsewhere (for
example in a JAR file).
Aehm, something got horrible wrong here: This RFE is marked as M18, but requires
that bug 16959 ("bookmark provider API") gets implemented _first_ - but it has
been marked as M20 ;-(
Any comments ?
Move to M21 target milestone.
Target Milestone: M18 → M21
Slamm isn't working on Mozilla anymore. Reassigning to default component owner.
Assignee: slamm → ben
marking 'helpwanted' and sending to nobody. 
Assignee: ben → nobody
Keywords: helpwanted
Target Milestone: M21 → Future
Netscape Nav triage team: this is not a Netscape beta stopper.
Keywords: nsbeta1-
It looks like it's been a while since this bug has touched...  The bug this
depends on is marked as invalid, but likely bug 16959 comment #9 applies here as
well:  this can be done with RDF.  Now that site icons have entered into the
picture, I'm not sure if there's anything left to do in this bug, if and when
they are enabled.

My best guess is that the reporter wants something different from site icons in
two ways:

1) The chosen images should be arbitrary, not necessarily the one the site
specifies.
2) The associated image should be allowed to be larger (or smaller?) than site
icons.

Roland, please clarify for me.  :)
Product: Browser → Seamonkey
QA Contact: claudius → bookmarks
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → EXPIRED
Still a valid enhancement request.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: EXPIRED → ---
Status: REOPENED → NEW
As now bookmarks stored in sqlite and having favicons, is this RFE still valid?
Priority: P3 → --
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA/WONT?]
I think the original comment was referring to thumbnails of the bookmarked page. I'd say this is WONTFIX and most probably extension fodder.
Status: NEW → RESOLVED
Closed: 12 years ago10 years ago
Resolution: --- → WONTFIX
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA/WONT?] → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.