Javascript document alert does not wrap text correctly

RESOLVED DUPLICATE of bug 40508

Status

()

--
trivial
RESOLVED DUPLICATE of bug 40508
15 years ago
14 years ago

People

(Reporter: xaxio, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040622 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040622 Firefox/0.8.0+

I put up an example at http://xaxio.com/converged/contact2.php -- the alert box
that JavaScript throws up doesn't wrap long lines of text.  This doesn't seem to
behave correctly.

Reproducible: Always
Steps to Reproduce:
1.Go the the above page USING FIREFOX
2.Wait for the popup box and observe
3.

Actual Results:  
Javascript alert box popped up without wrapping text

Expected Results:  
Either expanded to the screen capacity to show the full length of the line (if
possible) or wrapped the text with a -> before the second line to show that
there is no space in the wrapping.

No theme, 256 megs ram, win xp, 433 mhz celeron processor, shell = bb4win

Comment 1

15 years ago
This seems like a duplicate of Bug 40508.

Comment 2

15 years ago
The difference between IE and Firefox in this bug seems to be that IE breaks
words when soft-wrapping doesn't work, not that IE soft-wraps at places Firefox
doesn't. So yeah, it's a dup of bug 40508, unless this code is forked between
Firefox and Seamonkey.
dupe to bug 40508 or NEW ?
otherwise this one will rot ;-)

*** This bug has been marked as a duplicate of 40508 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.