Option to open external links in [current window | new window | new tab ]

RESOLVED DUPLICATE of bug 172962

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 172962
14 years ago
14 years ago

People

(Reporter: Andrew Burke, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

There should be an option in the preferences for dealing with links generated
outside of firefox (outlook, links on the desktop, etc.):  It should allow the
user to choose to open these links in one of three ways:

1) Replace current firefox session's foreground tab's contents, ie: current window
2) Open a totally new browser window
3) Open a new tab in the current session per the user's preferences on how new
tabs are opened

This should be a relatively simple change.  If I knew the code, I would submit a
patch.  As it is, I figure this is one of those '5 minutes for someone who knows
the code, 5 days for someone who doesn't' kind of changes.


Reproducible: Always
Steps to Reproduce:
1. Click a link in an external program.
2. See firefox 0.9 open a new window, even when you want it to make a new tab

Actual Results:  
Firefox opens a new browser window instead of the tab I wanted it to...

Expected Results:  
Open my external link in a new tab.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 172962 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.