Problem accessing websites from Windows "Run Dialog"

VERIFIED DUPLICATE of bug 246078

Status

()

VERIFIED DUPLICATE of bug 246078
15 years ago
15 years ago

People

(Reporter: sixxgate, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

I have come across a problem with Firefox on Windows that I know can also occur
in the Mozilla Suite (I will post this to them as well).

I recently had a problem trying to access websites by entering them into Windows
"Run Dialog". This problem is being caused by Mozilla and Firefox not properly
removing or editing certain entries in the registry. These entries deal with an
old Windows IPC method called DDE. Some program or IE itself resite IE back to
my default browser and when I changed it back to Firefox windows would display
and error message everytime I used the "Run Dialog" for websites but STILL RUN
Firefox with the site I entered. The message reads as:

"Windows cannot find `http://www.website.com/`. Make sure that you typed the
name correctly, and then try again. To search for a file, click the Start
button, and then click Search"

Reproducible: Always
Steps to Reproduce:
1. Set Firefox as default browser
2. Set IE as default browser
3. Return Firefox as default browsder
4. Click "Start" button then select "Run"
5. Fill the Open: text box with a website URL.

Actual Results:  
Windows would display the following message but this open Firefox:

"Windows cannot find `http://www.website.com/`. Make sure that you typed the
name correctly, and then try again. To search for a file, click the Start
button, and then click Search"

Expected Results:  
Open Firefox with no error message.

I am posting this so that the developers can in the next release make sure than
when Firefox is set to the default browser that it deletes the following
registry key and all there sub-keys and values'

HKCR\HTTP\shell\open\ddeexec
HKCR\ftp\shell\open\ddeexec
HKCR\gopher\shell\open\ddeexec
HKCR\https\shell\open\ddeexec

If anyone else on this forum has had this problem before you now know how to fix
it. It is a very rare and anyone who has had this problem, it is because these
DDEExec entries make windows look for IE starting instead of Mozilla (their
values point to IE).

Comment 1

15 years ago
Sounds like Bug 246078.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 246078 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
This bug still has not been fixed in the released builds of 0.9 but my report
includes how to fix it (it can be done manually, but the Firefox should be doing
this on it's own.)
a) no one's written a patch yet
b) no 0.9 releases would have this fix, the bug exists in 0.9, it would only be
fixed in subsequent versions
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.