Double-clicking filesystem URL shortcut generates extraneous error dialog

RESOLVED DUPLICATE of bug 246078

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 246078
14 years ago
14 years ago

People

(Reporter: Joel A. Foner, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Double-clicking a desktop shortcut (or a shortcut created in any folder on the
system) triggers an error dialog that states "Windows cannot find
'url-of-desktop-shortcut'. Make sure you typed the name correctly, and then try
again. To search for a file, click the Start button, and then click Search."

Although this message appears with an OK button that must be clicked to dismiss,
Firefox does open and goes to the correct URL. 

Reproducible: Always
Steps to Reproduce:
Preamble - Install Firefox 0.9, without developer tools, and enable as default
browser.
1. Browse to any web site
2. Drag from URL bar to dssktop to create a desktop shortcut to the web site
3. Close Firefox
4. Double-click desktop shortcut

Actual Results:  
System alert box appears stating that Windows can't find the destination, yet
Firefox opens correctly to the site.

Expected Results:  
No error dialog should be raised by Windows, since the browser results are correct.
(Reporter)

Comment 1

14 years ago
Created attachment 151792 [details]
Screen shot of error dialog

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 246078 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.