If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

E-mail and news articles sent in US-ASCII instead of the charset I chose

RESOLVED DUPLICATE of bug 247958

Status

MailNews Core
Internationalization
RESOLVED DUPLICATE of bug 247958
13 years ago
9 years ago

People

(Reporter: Alan Siu-Lung Tam, Assigned: smontagu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Problems created:

1. UA should respect my choice. User may feel frustrated when the mail is not
sent in the chosen encoding. 

2. If the mail is sent in US-ASCII, when the recipient replies and typed some
non-ASCII text, and his UA is not smart enough to warn him for another charset,
the replying mail is sent broken.

3. Even if the UA in (2) is smart enough, it has all the choices for charset. We
failed to tell the recipient side what charset we are happy to receive.

4. Further problems if the subject line is non-ASCII, because some UA fails to
deal with different encoding in subject and body.

Reproducible: Always
Steps to Reproduce:
1. Compose a new mail
2. Choose UTF-8 as encoding
3. Type some ASCII text in subject and body
4. Send

Actual Results:  
Mail is sent in UTF-8 encoding.

Expected Results:  
Mail is sent in US-ASCII encoding.

This problem is forked from bug 204087. It has been occuring for over a year but
no one ever cares the problems, both the one described in that bug and this
side-problem.

Given this bug, mails sent still works, but there is no workaround for this
problem - there is no way I send an e-mail with the same content in the encoding
I want. This makes the UA somehow handicapped.
(Reporter)

Comment 1

13 years ago
Typo.

Actual Results:  
Mail is sent in US-ASCII encoding.

Expected Results:  
Mail is sent in UTF-8 encoding.

Comment 2

13 years ago
There's already a patch ready for check-in. 

*** This bug has been marked as a duplicate of 247958 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
Tam, you said that this bug was "forked from bug 204087."  Since bug 247958 
(which this is duped to) has been fixed, is 204087 also fixed?  (I'm having a 
difficult time understanding all the details of the two bugs, altho I understand 
what the fix in 247958 does.)
(Reporter)

Comment 4

13 years ago
Bug 204087 is about subject encoding not agreeing with that of body.

The problem arises because the body is subject to USASCII conversion (fixed in
bug 247958 now) while the subject is not. This disagreement again makes some UA
unhappy, noticeably OE.

Bug 204087 is essentially one use case for this bug. As per the fix of this bug,
this disagreement will not occur any more. I suppose bug 204087 can be
considered fixed. I think the original submitter of that bug can be asked to
confirm this.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.